PKGBUILD 702 B

123456789101112131415161718192021222324252627282930
  1. # Maintainer: Ysblokje <ysblokje at gmail dot com>
  2. pkgname=('gamemode-git')
  3. pkgver='1.5-dev'
  4. pkgrel=1
  5. pkgdesc="GameMode is a daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS."
  6. arch=('x86_64')
  7. url="https://github.com/FeralInteractive/gamemode.git"
  8. license=('MIT')
  9. depends=('systemd' 'polkit')
  10. makedepends=('meson' 'pkg-config')
  11. provides=('gamemode')
  12. source=("git+https://github.com/FeralInteractive/gamemode.git")
  13. sha256sums=('SKIP')
  14. pkgver() {
  15. cd gamemode
  16. echo $(git rev-parse --short HEAD)
  17. }
  18. build() {
  19. cd gamemode
  20. arch-meson build
  21. cd build
  22. ninja
  23. }
  24. package() {
  25. cd gamemode/build
  26. DESTDIR=$pkgdir ninja install
  27. }